USAGE NOTE:

This lens features a KAF4 lens mount compatible with an electromagnetic diaphragm control system. Cameras compatible with this system are K-1 Mark II, K-1, K-3 Mark III, K-3 II, K-3, KP, K-70, K-S2, K-S1 and K-50. For K-1, K-3 II, K-3, K-S2, K-S1 and K-50, the camera’s firmware must be upgraded to the latest version.
If this lens is mounted on a camera without proper firmware upgrade, its diaphragm control mechanism becomes inactive, making it impossible to obtain correct exposure.